AD Photo Edit Version 1.5 Released

April 29, 2011 — 13 Comments

I have received a few requests for new features in my AD Photo Edit application recently, so I have released a new version that includes all of these features. There are a couple of small changes to the Free Edition but the majority of the new features are in the bulk import and bulk export functions of the program so only appear in the Bulk Edition.

You can find a summary of the changes below – thanks to all those that took the time to send me their suggestions for new features, I hope the new version does everything you wanted.

  • Bulk import option to only import photo if accounts do not already have a photo
  • Bulk export option to delete photo from AD account after exporting
  • Choose if you want to see all accounts, only accounts with no photo, or only accounts with a photo
  • Choose which attribute your images are named with for bulk import (Username, Full Name, or any specified LDAP attribute)
  • Contacts can now be bulk imported using the Named Images method as well as the CSV File method
  • Bulk import progress window displays user/contact display name for each account once the account has been found in the domain
  • Minor GUI changes

Anyone already using the application can just click the Check For Updates item on the Help menu to get the new version. Anyone who buys the standard edition or downloads the free edition from now on will get the latest version anyway. Both editions can be downloaded from here: http://www.cjwdev.co.uk/Software/ADPhotoEdit/Info.html

As always, if you have any feedback at all (good or bad) I would love to hear it.

Thanks, Chris

13 responses to AD Photo Edit Version 1.5 Released

  1. 
    Mikey Mccorry May 17, 2011 at 04:58

    Hi Chris! Thanks for your work on this useful app. I’ve been trying out the free version and I get the following error when I click OK to save the new image to Active Directory:

    Error updating thumbnailPhoto attribute for CN=Mikey McCorry,OU=Information Technology,OU=My Company,DC=mycompany,DC=com,DC=au on domain controller DC01.mycompany.com.au : An operations error occurred.

    Our DC server is Windows Server 2008 R2. Any ideas?

    • 

      That is odd – are there any special characters (comma, backslash etc) in the path to the user you are trying to modify? I know there aren’t in your example but not sure how much you have edited that. Also do you get this error for all users or just some?

    • 

      Oh and also, are you running this on your ‘local’ domain and with your current credentials or have you specified a different domain and credentials in the Tools -> Options window?

      • 
        Mikey Mccorry May 17, 2011 at 23:55

        Thanks for replying. This is happening when I try to save a new image to any user, including myself. Yes, the error was slightly edited, but only the ‘mycompany’ part, which doesn’t have any special characters.

        This is running just with my current credentials, however, I had to manually enter the domain into the Options window, as when I selected ” I got the following error when I try to save:

        Error locating domain controller: The specified string parameter is empty.
        Parameter name: name

        … which I figured wasn’t getting as far as when I manually entered the domain. I’m not sure if there’s anything else special about our particular AD configuration that I could tell you, unfortunately.

      • 
        Mikey Mccorry May 18, 2011 at 00:30

        All fixed. Apparently my account didn’t have write permissions to AD. *facepalm* It’s now fully working! Thanks very much!

      • 

        lol ah that would explain it then 🙂 Its a shame AD doesn’t throw back a more useful error like Access Denied but hey at least you got it sorted.

  2. 

    Very neat tool!
    Hey, big organizations will sometimes have their users behind authenticating webproxies (mine is using the logged on enduser cached credentials) – in such a case the version update will fail with an HTTP 407 and suggest to disable the the version check (cool!).

    Perhaps an idea for your next release… maybe not – guess most guys will manage.

    • 

      …I mean, I’m sure .Net would allow you to automate that – although system.net syntax is somwhat foxy

  3. 

    Hello,
    I used this util to post pics but now am being asked to back out the photos. after I deleted them, they’re still showing up in people’s Outlook/Emails and Contacts. Assuming Outlook is caching some of this data, is there some way to delete this data manually or some scripted way? thanks in advance – Z

    • 

      I’m afraid I don’t know how you could clear the Outlook cache, but I would be surprised if Outlook is actually caching this information between sessions (as in after you close and restart Outlook). Are you sure you actually deleted the images and that this has replicated to the domain controllers that your Outlook users will be using?

  4. 

    I’ve restarted OUtlook a few times and they still seem to be showing up. And yes, I’ve definitely deleted them using your utility. i know this because I removed them all and when i use the app to query all of those who have pictures, the list comes up empty.

    • 

      Hmm I’m not sure then if you’ve tried restarting the PC as well – I’ve deleted them in the past and they have been gone as soon as I restarted Outlook. You might get some answers if you post on the Microsoft Outlook forums/newsgroups. Sorry I can’t be of more help, I hope you appreciate this is not an issue with AD Photo Edit and more of an Outlook problem

      • 

        yeah, just wish i could get to the bottom of this is all will try rebooting now to see if that works. thanks

Leave a Reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out / Change )

Twitter picture

You are commenting using your Twitter account. Log Out / Change )

Facebook photo

You are commenting using your Facebook account. Log Out / Change )

Google+ photo

You are commenting using your Google+ account. Log Out / Change )

Connecting to %s